Dual balance

Var ett tag sen jag skrev nu. Inte riktigt för att jag inte gjort nått men, livet händer ju och sen har jag inte varit så sugen heller på att skriva så. Iallafall, jag har väntat i ca tre månader på en ny ESC till min longboard och fick den äntligen för några veckor sen(Det blir en annan post). Inför den händelsen och sommaren med bra väder att åka bräda så köpte jag en ny starkare laddare och fler batterier. Laddaren är en Turnigy reaktor 250w och ett nätagg till den ochså en reaktor på 350w. Egentligen ville jag köpa laddaren på 300w då den klarar upp till 20A mot endast 10 på denna, men den fanns inte i lager då jag beställde och, egentligen behöver jag inte mer än 8A för två 4Ah batterier parallellt.

För att kunna ladda batterierna parallellt behövs dock kablage för att kunna koppla in båda samtidigt, jag gjorde en Y-kabel för högströmsanslutningen till batterierna för att driva brädan med men balanseringskontakten för att övervaka batteriet måste även gå att koppla in för att ladda på ett säkert sätt.

image

För detta beställde jag redan förra året hon och hankontakter till balanseringskabeln. Dessa är väldigt enkla då de endast ska koppla ihop alla ledare med samma ledare på kabeln från de andra batterierna. Först tänkte jag endast löda fast dem direkt på en kabel med krympslang på men plasten i kontakterna var lite känslig för värmen från lödpennan. Så jag tänkte att det är lättare att hålla koll på hur mycket jag värmer dem om jag sätter dem på ett kort istället. Och så vred jag ner värmen på pennan 😉

image

Efter att ha lött dit alla kontakter plus kabeln.

image

Lödöarna kopplas ihop med lödbryggor, var extra noga här så det skulle bli någorlunda separation mellan raderna. Efter detta mätte jag noga upp allt med multimetern för att säkerställa att det inte var kontakt mellan några ledare… vore inte så kul att koppla in den om det vore det, kablarna skulle antagligen brinna av med skador på batteriet/brandrisk som följd.

image

För att skydda undersidan med exponerade kontakter skrev jag ut en liten botten som sedan limmades med smältlim, blev riktigt snyggt!

image

Baksidan. Ses!

Annonser

Epoxyd

Ojojoj… Limmat hjulen med två komponentsepoxy nu.

image

image

Här ser ni lite hur det förra drivhjulet ser ut efter att jag tog av kugget, fullt med sprickor, bitar som lossnat. Inte så kul att se då lagren var lösa och däcket kunde flexa rätt mycket.

image

Nå! Här är en bild efter att jag limmat första hjulet. Jag var inte försiktig direkt, jag trodde limmet skulle vara rätt tjockt men det är nog den andra sorten jag har som är det. Satte i lagren, med en m8-bult igenom (glömde visst fota), superlimmade alla lösa bitar som inte försvunnit, ställde hjulet på högkant och hällde lim i mitten.

image

Vilket började flyta undan så jag la på mer… Och sen kom det ut på undersidan 😦 såklart. Men nu vart det ju bråttom, hur lösa detta?? Tog en näve tidningspapper och knycklade in det på undersidan och hoppades på det bästa.
Nästa dag såg jag att det faktiskt funkade hyffsat, det mesta av limmet var där det skulle. Men nu var det ju lim över hela bulten, vilket göra att få lös den.
Men till nästa hjul måste jag ha en bättre lösning!

image

Så då tänkte jag på… Häftmassa! Annan lerliknande massa funkar säkert men man tager vad man haver.

image

Så med toppen av bulten säkrad och botten tätad av kugget och massan borde det väl bara vara att hälla på limmet igen?

image

Nä, såklart inte. Nu ville inte limmet rinna ner, så sen följde en kletig session av att försöka lossa skruvarna till kugget, lyfta på fästringen(den vita som syns på bilden ovan), hälla på mer lim och sen skruva ihop allt igen.

Lim överallt, tur jag hade handskar iaf.

image

image

image

Mount

Oj! Ser att jag visst glömt lägga upp några bilder på brädan!

image

Jag har såklart monterat på motorn och testat den nu!

image

En lite dum detalj var att jag använt gänglåsning på kugget som sitter på motorn, så det sitter där det sitter kan man säga. Så för att få dit motorn fick jag börja med att såga i mitt fäste :/

Just då orkade jag inte skriva om det dock, när jag sen glad i hågen skulle testa den så ! Fungerade inte motordrivaren! :(!! Jag vet fortfarande inte riktigt varför. Men just då så blev jag så less, den funkade ju sist jag körde… Så jag suckade och kollade upp retur-proceduren  och väntade på att få skriva ut pappren till det. Gissade på att den råkat bli för varm eller blöt, båda två har ju hänt. Surt.

Tänkte dock att jag skulle testa koppla den mot datorn innan jag skickade iväg den för gott, så jag gjorde det i helgen. Och sen startade den!? Känns rätt udda då den bara legat i lådan.

Det var inte bara därför jag kände mig lite nedslagen dock, drivhjulet har spruckit. Verkar som att de lever ett hårt liv, det blir väl fjärde hjulet som gått åt nu. Tänker att det kanske går att fylla dem med epoxy så de blir mer solida men, ska jag då göra det på två hjul då kanske och använda ett som är helt som nytt drivhjul och det trasiga på andra sidan? Bara jag inte råkar limma ihop hela hjulet bara 🙂
Men tyvärr så blir det nog att inhandla nya hjul till sist ändå, och några dyr-öres som förhoppningsvis håller bättre.

Svets!

image

Fick denna bild på min nya truck, alltså !!! Hur bra som helst!
Med alla olika legeringar av aluminium och utan att ens var säker på vad trucken är gjord av så vart det ändå grymt.
Sen har jag fått veta att det finns utrustning för att svetsa alu på Komtek med, så det är kanske något jag får prova själv vid tillfälle.
Synd bara att det är så lång till sommaren 😉

Tjohoo!

image

Har frågat runt lite bland vänner och bekanta om det är någon som kan/känner någon som kan svetsa aluminium för ett nytt motorfäste till brädan. Känns som att det är rätt sällsynt, det tog säkert ett par månader innan jag fick höra att Tomas har en bekant som var villig.
Men vad gör det, det är ju ändå vinter!!

image

Efter att gjort några prototyper på skrivaren (maskinerna hjälper varandra 😉 så var det dags att realisera designen i metall. Har faktiskt det lite tunt med bits nu då mina trotjänare  3mm tog mycket stryk då jag gjorde plåtarna till fräsen, hade bara en kvar och den såg sliten ut. Men jag handlade en bunt 1.5 mm som jag tänkt använda till kretskort… Så de fick duga.

image

Så en tunn liten fjuttfräs mot 5mm härdat aluminium?? Gick rätt bra faktiskt, men slutnotan hamnade trots det på tre dödsfall.. 😦
De första två var på grund av ett avrundningsfel, när man skär mjuka former skickas kommandon för cirkelbågar. Dessa valideras sedan för att vara matematiskt korrekta, att det går att ta sig från nuvarande position till nästa med de parametrar som skickats. Vilket låter ju bra?

image

Inte så bra om programmet sen fortsätter! Som ni kanske ser är det två spår i nedersta hörnet, där den först skippade böjen i hörnet och fortsatte mot nästa hörn i en rak linje. Vilket hade väl gått bra om den gjort så hela vägen, men när den nästan var igenom så blev bågen kortare pga 3Dmodellen och då accepterades den, den var nu inom toleranserna. Alltså 1.5 mm bits vs ca 4.5 mm plåt. Den rök som en tandpetare.
Lösningen på detta var att öka noggrannheten, från 0.01 mm till 0.001!! Skulle aldrig hittat detta om den inte klagat på programmet, sen när jag ställt om till fler decimaler så använde jag testläget i grbl, $C. Mjukvaran i fräsen tar då emot kommandon precis som vanligt men rör inte på fräsen utan kontrollerar bara om de är giltiga och ber sen om nästa. Den gick från 66 ogiltiga kommandon till noll, trots detta kändes det lite tveksamt att starta samma program en tredje gång, med en tredje likadan bit.

image

Men det gick ju vägen! Här är baksidan och de tabs som håller allt på plats tills det är klart.

image

Prototyp och färdig del! Ouch! Tog även med 3Dkonturen mot trucken 😉
Men den tredje bitsen då? Kände mig lite tuff inför sista skäret så ökade hastigheten till det dubbla! Vilket gick ett tag men sen rök den med. De parametrar som funkade var 500mm/min, 10 000 rpm och 0.3 mm skärdjup.

image

Yea 😀 kul att hitta en bra kombo för att skära alu med! Även om det gick några bits så lät det bra och blev snygga skär, så utan missöden bör det gå utan problem. Jag tror att en mindre fräs är rätt lämpligt med, med 3 eller 4 mm bits som jag testat förut gick det lite väl tungt, även om den verkade klara det. De single flute bits jag använt till alu tidigare är visserligen bra ut temperatursynpunkt, men nu har jag lärt mig att de även skapar mycket vibrationer och en obalans i skäret som är svår att hantera och som i slutändan gör att bitsen lättare går av!

Physics!

Eller nördighet, beroende på vem man frågar.

image

Var lite nyfiken på hur branta backar jag skulle kunna köra upp för med brädan, sen kom jag på att det kan jag ju faktiskt räkna ut med fysiken jag lärde mig i gymnasiet!
Sen eftersom jag tydligen har lite att göra ibland så kodade jag det till en graf i octave(matlab i linux, för den som vet vad matlab är… 😉 ). På mobilen, dessutom, som jag förresten fixat nu!

Och eeh… den finns i 3D med! 😉

image

Dock så, dessa värden är såklart räknade förenklat utan förluster så som luft- och rullmotstånd, friktion och skräp på vägen. I verkligen behövs det kanske dubbelt så hög effekt, speciellt för högre farter. Men det visar ändå att det inte behövs så mycket energi till el liten farkost.. Jämför mot en bil som säkert ligger 20-30 eller kanske tom 50 ggr högre!

The last ride…?

2015-10-18 18.38.56

Jag har fått mina nya hjul! Och de är helt grymma, rullar sjukt lätt i jämförelse mot de gamla och eftersom de är större äter de upp stenar och annat skräp på vägen mycket bättre. Nästan så jag höll på att ralma då jag skulle prova dem första gången då brädan bara ville sticka iväg 😉

2015-10-18 18.41.18

Medan jag väntade på hjulen skrev jag ut nya kugg som passade just denna modell(dessa och även båda dessa), tänkte ta de med lite fler kugg för att få samma utväxling då större hjul -> större omkrets -> högre fart/mindre kraft, men blev remmen för kort! CIMG8662

De nya hjulen är dock bredare än de gamla så fick flytta in fästet en bra bit för att det skulle passa. Är inte så optimistisk om att motorfästen i plast är starka nog nu dock så orkade inte rita om dem, efter en ordentlig omgång med bågfil och vanlig fil dock så passade de hyffsat ändå. Och med lite(mycket) lim sen så verkade det sitta. Fick även hem min beställning på ett motordrev i metall så passade på att byta till det!

Så, hur gick då första åkturen med de nya däcken? Super! 😀 Trots att jag endast laddat batterierna till kanske 50% så var jag ute i ungefär 25 minuter och brände på uppför backar och över torget på kullerstenen! Sen tog det slut ungefär 10 meter från dörren hemma så jag gick in och la mig rätt nöjd ^^CIMG8664

Sen dagen efter då jag laddat batteriet och tänkte faktiskt använda brädan som transportmedel och åka ner till Komtek(ska skriva om det sen med, men tills vidare är det hemligt!) så fungerade den inte alls! Istället för att tuta som vanligt(med motorn) när jag slog på strömmen så var det en annan ton i luren 😦 Normalt är den ganska högljudd och tutar glatt en melodi, nu var det en låg, trött ton en gång per sekund tills jag stängde den igen. Så jag fick gå istället 😦

När jag senare kollade upp det stod det i manualen att detta betydde att den inte fick någon signal från radiomottagaren, men då jag mätte upp det och sedan kollade på oscilloskopet så var det tydligt att den fick en signal och att den såg ut som den ska. Mer än troligt så har den(min esc) gått över till de sälla jaktmarkerna.

Det jag tror hänt är att en av de mosfets som styr motorn brunnit, då jag mätte motorkontakterna mot jord så var det en av dem som endast visade 20 ohm. Vilket tyder på att nått inte är som det ska, då de bör vara kopplade på samma sätt och då bör visa samma värde då strömmen är av.

Så frågan är då varför? Jag är lite kluven, escn är ju både liten och billig, endast 60A mot de som andra byggare använt på 120-150A. Men samtidigt så, vad jag räknat fram från de knappfaldiga uppgifterna på hemsidorna så bör motorn inte kunna dra mer än 44A med det batteriet jag har. Så.. ja vad har hänt?